WordPress插件更新“需要访问您网页服务器权限”

[复制链接]
admin 发表于 2017-2-11 16:15:44 | 显示全部楼层 |阅读模式 简体中文繁體中文

广州市

“无法连接到文件系统,请确认您的凭据。要执行请求的操作,WordPress需要访问您网页服务器的权限。 请输入您的FTP登录凭据以继续。 如果您忘记了您的登录凭据(如用户名、密码),请联系您的网站托管商。”上面啰嗦了这么多意思就是你的权限不够,不允许升级。

分析问题:出现这个提示是因为网站文件的所有者和网站文件夹的所有者不同导致的。仔细看了一下网站文件夹所有者和用户组是www,而网站文件所有者和所在用户组是root。

那么现在可以下手解决这个问题了。用Xshell连接到VPS上,输入

chown -R www /home/www/网站文件夹

把上面的root修改成www就解决了。

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册/Sign up

本版积分规则

恶趣味 ( 粤ICP备15065270号

GMT+8, 2018-7-18 20:26

WWW.EQUWEI.COM

© 2001-2016